Stagecoach

I’m getting prompted to update the app but it’s not working.

For the app to work properly, please make sure your iPhone software is version 10 or later.